Forums  ›  Dolphin 7  ›  General
 

Safe Mode

I can not install because of safe_mode.

safe_mode is On, disable it
Please go to the
Dolphin Troubleshooter
and solve the problem.

If your host has the server configured php as apache dso module you can try adding to the main .htaccess file (yoursite.com/.htaccess) the following:

php_flag safe_mode Off

If your host has the server configured suphp, cgi, fast-cgi, or similar you can try adding to php.ini or creating a php.ini (yoursite.com/php.ini) with the following:

safe_mode = Off

You can also politly ask your host if they will set safe_mode off for you.


You can also disable the check for safe_mode in:
yoursite.com/inc/header.inc.php

About halfway down the file you will find something like:
define('CHECK_DOLPHIN_REQUIREMENTS', 1);
if (defined('CHECK_DOLPHIN_REQUIREMENTS')) {
//check requirements
$aErrors = array();

$aErrors[] = (ini_get('register_globals') == 0) ? '' : '<font color="red">register_globals is On (warning, you should have this param in Off state, or your site will unsafe)</font>';
$aErrors[] = (ini_get('safe_mode') == 0) ? '' : '<font color="red">safe_mode is On, disable it</font>';


You can edit this at your own risk. Be sure you make a back up of the file if you go this route. Same with the .htaccess file or php.ini file.

Ask your host would be the best option. Then, .htaccess or php.ini file change would be next. Thirdly, editing header.inc.php to do away with the check is not a very good option because your site would still be running with safe_mode on.

Forums  ›  Dolphin 7  ›  General